[Updated] Advisory: Defect in latest Java update prevents execution of openthinclient-Manager

Update

Oracle released a new version Java 8u144, resolving the issue described below. openthinclient advises its users to update to this version.


 

Summary

Execution of openthinclient-Manager ist not possible with the latest version of Oracle Java. openthinclient advises against installing this version of Java on computers where the openthinclient-Manager is used.

Affected products and versions

  • openthinclient-Manager
    • all versions
  • Oracle Java
    • 8u141
    • 1.8.0_141-b15
    • 1.7.0_151-b15
    • 1.6.0_161-b13

Cause of failure

The july update of Oracle Java contains among other things changes in the validation process of JAR files. In the course of this process a particular formatting in the metadata of the JAR can result in an misleading error.

At least one of the libraries used by the openthinclient-Manager is affected by this.

As a Webstart application the openthinclient-Manager is verified at each start. Due to the issue mentioned above the startup of the application is aborted with an error.

Solution / Workaround

Oracle is aware of this issue and working on a solution.

In the meantime openthinclient advises to forgo updating to the latest Java version, or to downgrade to the previous version, on computer where the openthinclient-Manager is used.

More information

Oracle Java 8u141 Update Release Notes:
http://www.oracle.com/technetwork/java/javase/8u141-relnotes-3720385.html

This entry was posted in News. Bookmark the permalink.